Back to overview
Maintenance
Update 2026.06.01
Feb 26 at 10:05am CET
–
Feb 26 at 11:05am CET
Affected services
app-eu
app2-eu
app-us
Resolved
Feb 26 at 10:05am CET
Hotfix
Affected services
Resolved
Feb 26 at 10:05am CET
Hotfix
Affected services